Page 2 of 2

Re: Talkback Comp Build Thread

Posted: Tue Dec 10, 2019 8:45 pm
by mrclunk
I'm sorry Joe, i ment to update my post...
Mic worked fine using the standard (2 x 6k8) supply as on the pcb. It's an Astrada conference mic 952.353UK (just the gooseneck mic part)
All working nicely on our Calrec. I added a 1k Log pot across the output for volume and a cheap OEP a262a2e transformer to split the output.
One to the desk auxs and a separate out to patchbay for remote session down Skype etc.

Re: Talkback Comp Build Thread

Posted: Tue Dec 10, 2019 9:57 pm
by Joe Malone
mrclunk wrote:I'm sorry Joe, i ment to update my post...
Mic worked fine using the standard (2 x 6k8) supply as on the pcb. It's an Astrada conference mic 952.353UK (just the gooseneck mic part)
All working nicely on our Calrec. I added a 1k Log pot across the output for volume and a cheap OEP a262a2e transformer to split the output.
One to the desk auxs and a separate out to patchbay for remote session down Skype etc.
Cool great to hear you got it all working :-)

Re: Talkback Comp Build Thread

Posted: Sat Aug 22, 2020 12:28 am
by mrclunk
I have a slight issue with the TB amp.
I'm getting a loud pop when turning the TB on and off.
Is there a way to eliminate this?

Could it be DC on the relay contacts?

Re: Talkback Comp Build Thread

Posted: Sat Aug 22, 2020 9:49 am
by Joe Malone
mrclunk wrote:
Sat Aug 22, 2020 12:28 am
I have a slight issue with the TB amp.
I'm getting a loud pop when turning the TB on and off.
Is there a way to eliminate this?

Could it be DC on the relay contacts?
HI if built properly there should not be any dc on output. If getting pops make sure you are not sending phantom power into the output and there is no dc voltage leaking to the output xlr pin 2 & pin 3. Measuring with a meter from 0v to pin 2 and pin 3 will show if voltage is there or not. Try measuring with nothing plugged int the output first and then with it plugged in and let me know what find.